QmailtoasterMain Page | About | Help | FAQ | Special pages | Log in

Printable version | Disclaimers | Privacy policy | Latest revision

Dependencies Required for QmailToaster Install

(Difference between revisions)

 
Line 1: Line 1:
-
  This is an example. You will find the proper dependency
+
This is an example. You will find the proper dependency
-
script file in the utilities directory for your distro.
+
script file in the utilities directory for your distro.
  This is a list of the packages required for QmailToaster
  This is a list of the packages required for QmailToaster

Latest revision as of 21:35, 12 June 2006

This is an example. You will find the proper dependency
script file in the utilities directory for your distro.
This is a list of the packages required for QmailToaster
to install and run properly for a basic install of CentOS 4
If you use a different distro, this should provide a good
guideline for you to follow.
#
# CentOS 4 dependencies for basic install
#
# This covers the required packages when you DID NOT
# check anything when you installed CentOS 4
#
# Removes sendmail and adds all deps
#


Note: SELinux must be disabled


# Remember to import the keys so yum works,
rpm --import /usr/share/doc/centos-release-4/RPM*


# Remove sendmail with either:
yum -y remove sendmail  OR  rpm -e --nodeps sendmail


# You need the following packages installed
autoconf automake automake17 bzip2 bzip2-devel curl curl-devel expect 
expect-devel gcc gcc-c++ gcc-g77 gcc-java gdbm gdbm-devel gmp gmp-devel 
httpd httpd-devel httpd-manual httpd-suexec krb5-auth-dialog krb5-devel 
krb5-libs krb5-workstation libgcc libidn libidn-devel mysql mysql-bench 
mysql-devel mysql-server mrtg ntp openssl openssl-devel pcre 
perl-Digest-HMAC perl-Digest-SHA1 perl-Net-DNS perl-Time-HiRes 
php php-ldap php-mysql php-pear rpm-build rpm-devel rpm-libs rpm-python 
sed setup setuptool spamassassin stunnel system-config-date which