QmailtoasterMain Page | About | Help | FAQ | Special pages | Log in

Printable version | Disclaimers | Privacy policy

SSL on submission port

From Qmailtoaster

SSL on Submission port

Just trying some things out here I noticed that Outlook Express and qmail-toaster in ssl/require auth mode are not very compatible.

Have not figured out what exactly goes wrong, but it seems OE never gets to auth itself. Debugging SSL encrypted sessions is a bit dificult .... It does work with the Mail program from Vista.

Looking for ways to solve this, since using SSL on the submission port is pretty much required for security reasons I did find a way.

You have to use sslserver from ucspi-ssl (http://www.superscript.com/ucspi-ssl/intro.html) .

Change the smtp-submission run script by adding

export CERTFILE="/var/qmail/control/servercert.pem"

export KEYFILE=""

export DHFILE=""

and change tcpserver in sslserver

At least that works here :) If anyone has a rpmish version of ucspi-ssl or a simular program please report!

Retrieved from "http://wiki.qmailtoaster.com/index.php/SSL_on_submission_port"

This page has been accessed 9,571 times. This page was last modified on 14 January 2007, at 22:04. Content is available under GNU Free Documentation License 1.2.


Find

Browse
Main page
Community portal
Current events
Recent changes
Random page
Help
Edit
View source
Editing help
This page
Discuss this page
New section
Printable version
Context
Page history
What links here
Related changes
My pages
Log in / create account
Special pages
New pages
File list
Statistics
More...